Problème avec l'attribut "margin" dans le css de base

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec l'attribut "margin" dans le css de base

Message par GeckoVenus le Dim 16 Aoû 2015 - 20:19

Détails techniques


Version du forum : PunBB
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Internet Explorer
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : http://forumbacgtarp.gtaboard.com/

Description du problème

Bonjour, Je suis nouveau sur ce forum et je n'ai pas trouvé de réponse via une recherche, donc je pose ma question.

Je suis en train de mettre au point un forum et j'ai une question sur le css. Je voudrais en effet totalement supprimer l'attribut
Code:
* {
    margin: 0;
}
Du css du forum car cela donne un effet très beau à la mise en page quand je désactive cette ligne via Chrome (avec f12).

Avec la ligne activée :


Sans la ligne en question :


Le problème c'est que cette ligne fait partie du css de base, donc non-modifiable et de plus elle possède la valeur 0 (valeur par défaut de margin) donc impossible de la remplacer par la valeur "nul" dans le css perso, il me faudrait vraiment la supprimer ou la desactiver.

Merci de m'avoir lu, j’espère que vous aurez une solution à mon problème.

Cordialement,
GeckoVenus.


Dernière édition par GeckoVenus le Lun 17 Aoû 2015 - 18:41, édité 1 fois

GeckoVenus
Nouveau membre

Messages : 4
Inscrit(e) le : 16/08/2015

http://forumbacgtarp.gtaboard.com/
GeckoVenus a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec l'attribut "margin" dans le css de base

Message par néco le Lun 17 Aoû 2015 - 18:33

Et si tu mets la valeur de ton choix dans ta feuille de css et que tu y rajoute
Code:
!important
derrière , ça ne marche pas non plus ?


PS : tu ne devrais pas mettre tes captures d'écran sous hide , car des gens qui ne peuvent pas voir une question en entier , c'est des gens forcément moins ''motivé'' pour répondre ( répondre à l'aveuglette c'est pas ce qu'il y a de plus simple Wink )


Bizzz

néco
*****

Féminin
Messages : 781
Inscrit(e) le : 13/02/2013

http://pephenix.forumactif.org/
néco a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec l'attribut "margin" dans le css de base

Message par GeckoVenus le Lun 17 Aoû 2015 - 18:41

Merci beaucoup pour la réponse mais j'ai fini par obtenir un résultat similaire en utilisant :
Code:
.main .main-foot, .main .main-head {padding: 20px 29px;}

Je passe donc le sujet en résolu Smile

PS: merci pour le conseil des captures Wink

GeckoVenus
Nouveau membre

Messages : 4
Inscrit(e) le : 16/08/2015

http://forumbacgtarp.gtaboard.com/
GeckoVenus a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum