switch_user_logged ne fonctionne pas toujours ?

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu switch_user_logged ne fonctionne pas toujours ?

Message par Xëanus le Mar 15 Déc 2015 - 6:19

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox
Personnes concernées par le problème : Moi uniquement
Lien du forum : http://ile-du-coeur.forumactif.org/

Description du problème

Bonjour, j'ai un petit soucis avec les switch_user_logged.
Déjà je me suis rendu compte que, selon l'emplacement dans le code, ça ne fonctionnait pas toujours (j'ai pas trouvé là logique).
Mais selon l'emplacement que je lui ai donné dans viewtopicbody, ça fonctionne, mais pas entièrement : ça s'efface aux yeux des non connectés mais ça ne s'affiche pas pour les connectés. (Alors que pourtant je peux afficher des éléments qui apparaissent bien visible dans la même zone du code).
Y a-t-il des règles sur l'utilisation de user_logged ? L'exact même code fonctionne parfaitement dans d'autres templates, j'ai essayé de le positionner plusieurs fois mais là je sèche >.<

Voilà à quoi ressemble le code grosso modo :

Code:
<!-- BEGIN switch_user_logged_in -->
<div><span>Rencontrer les autres voyageurs</span></div>
<div><span>Déconnectez-vous avant de quitter !</span>
   <br/><span>Quitter les autres voyageurs</span>
</div>

  <!-- END switch_user_logged_in -->
 
  <div>Règles du jeu</div>
  <!-- BEGIN switch_user_logged_in -->
    <div>
  Fiche personnage</div>
    <!-- END switch_user_logged_in -->

Merci pour votre aide !

EDIT : Bon ok, encore un topic inutile... Ca vient bien du placement. C'est résolu. Par contre, si quelqu'un connait la logique, ça peut aider les futurs perdus !

Xëanus
*

Messages : 35
Inscrit(e) le : 23/03/2015

http://ile-du-coeur.forumactif.org/
Xëanus a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum