Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Problème font-size

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème font-size

Message par Yuuki-baka-baka le Jeu 29 Aoû 2013 - 17:36

Bonjour, je suis actuellement entrain d'essayer d'obtenir que mes sous-forums apparaissent en taille de 10px, mais je n'y parviens pas.
J'ai essayé de mettre font-size un peu partout... Que ça soit dans les classes CSS, ou dans les templates, mais rien à y faire, il reste définitivement à une taille trop grosse.
Et je ne peux pas réduire la taille des liens en général sinon ça gâche tout.

Voici le screen :


Les sous forums sont donc à gauche à côté du bouton avec la fille.

Et voici mon code du template index_box :

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
  <tr>
      <td valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <span class="gensmall">{LAST_VISIT_DATE}<br />
        {CURRENT_TIME}<br />
        </span>
        <!-- END switch_user_logged_in -->
        <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
        <!-- BEGIN switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
        <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
        <!-- END switch_user_logged_in -->
        <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
  </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <tr>
      <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th>
        </tr>
  <!-- END tablehead -->
  <!-- BEGIN cathead -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
        <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
              <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
        </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
  </tr>
  <!-- END cathead -->
  <!-- BEGIN forumrow -->
  <tr>
      <!-- BEGIN inc -->
        <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
        <!-- END inc -->
        <td>
            <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" class="pika" style="max-width:100px; max-height:100px;border-radius:20px;border:#FFFFFF 4px solid; z-index:999; margin-left:-60px; margin-bottom:20px;" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
        </td>
        <center><td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" align="center" valign="middle" width="100%" height="50">
                <span class="forumlink">
                    <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a>
                </span>
          <span class="genmed"><center><table><tr><br><td style="width:150px; font-size:10px;" class="lastpostvariante"><span class="gensmall" id="subforums">
  <!-- BEGIN switch_moderators_links -->
  {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
  <!-- END switch_moderators_links -->
            <b style="font-size:10px;">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</b>
</span>
<script type="text/javascript">
jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,' <br> ')).removeAttr('id');
</script></td><td style="margin:5px; margin-left:10px; width:450px;" class="violet">{catrow.forumrow.FORUM_DESC}</td><td class="row3 over" valign="middle" height="50" class="lastpost" >
        <span style="font-size: 10px; color: #000;text-decoration: none; background-image:url("http://img4.hostingpics.net/pics/455389Test2.png");">{catrow.forumrow.POSTS} Messages | {catrow.forumrow.TOPICS} Sujets. <br><br>{catrow.forumrow.LAST_POST}</span>
            </td></tr></table><br></center></span></td></center>
  </tr>
  <!-- END forumrow -->
  <!-- BEGIN catfoot -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
  </tr>
  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->
Et le code CSS concernant la partie des sous forums (je rajoute même ceux que j'ai essayé de faire pour forcer décidemment font-size à marcher)

Code:
.lastpost{
    padding: 5px;
    font-family: verdana;
    font-size: 10px;
    color: #000;
    border: 2px solid #FFF;
    text-decoration: none;
    -moz-border-radius: 5px;
    -webkit-border-radius: 5px;
    border-radius: 5px;
    -o-border-radius: 5px;
  background-image:url("http://img4.hostingpics.net/pics/455389Test2.png");
}

.lastpostvariante{
    padding: 5px;
    font-family: verdana;
font-size:small !important;
    color: #000;
    border: 2px solid #FFF;
  text-transform:uppercase;
    text-decoration: none;
    -moz-border-radius: 5px;
    -webkit-border-radius: 5px;
    border-radius: 5px;
    -o-border-radius: 5px;
  background-image:url("http://img4.hostingpics.net/pics/455389Test2.png");
}

a.lastpostvariante{
    font-size: small;
    color: #000;
  text-transform:uppercase;
}
Merci d'avance si quelqu'un peu m'aider ^^'...


Dernière édition par Yuuki-baka-baka le Jeu 29 Aoû 2013 - 17:51, édité 1 fois
avatar

Yuuki-baka-baka
Nouveau membre

Messages : 19
Inscrit(e) le : 02/04/2010

http://itsgravitation.forumactif.org/
Yuuki-baka-baka a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème font-size

Message par Self le Jeu 29 Aoû 2013 - 17:45

Bonjour ^^ .

Il s'agit normalement dans ce genre de cas de lien il faut donc essaye avec un "a" comme cela
Code:
.lastpost a{
font-size:10px !important;}
Cordialement Smile.
avatar

Self
Membre actif

Masculin
Messages : 3717
Inscrit(e) le : 13/06/2013

Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème font-size

Message par Yuuki-baka-baka le Jeu 29 Aoû 2013 - 17:50

Bon bah je vais réviser mes cours de code, vu que moi j'avais pas du tout placé le "a" au bon endroit xD.
Merci beaucoup ^^....
avatar

Yuuki-baka-baka
Nouveau membre

Messages : 19
Inscrit(e) le : 02/04/2010

http://itsgravitation.forumactif.org/
Yuuki-baka-baka a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum