Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

(#3557) Erreur sur le template overall_footer_end, par défaut

Voir le sujet précédent Voir le sujet suivant Aller en bas

En cours (#3557) Erreur sur le template overall_footer_end, par défaut

Message par jackymi le Mer 7 Mar - 19:06

Bonjour

Suite à ce topic Topic'it Connect : Activation, configuration et mode de fonctionnement , je me suis aperçu que le template par défaut  overall_footer_end , comportait une erreur sur un script en bas de page .

En effet , si on prend le template par défaut, que ce soit avant ou après la date annoncée , le mot <script> n'est pas complet .

Après

Code:

    <!-- END switch_facebook_login -->


Il devrait y avoir ceci


Code:

    <!-- BEGIN switch_topicit_connect -->
    <script type="text/javascript">
        $(document).ready( function() {
   $('div.ti-connect').attr({
       'data-loc' : '{switch_topicit_connect.TOPICIT_URL}',
       'data-login' : '{switch_topicit_connect.BOARD_LOGIN}',
       'data-version' : '{switch_topicit_connect.TOPICIT_VERSION}',
       'data-lang' : '{switch_topicit_connect.BOARD_LANG}'
   });
   (function(d, s, id) {
       var js, fjs = d.getElementsByTagName(s)[0];
       if (d.getElementById(id)) return;
       js = d.createElement(s); js.id = id;
       js.src = "{switch_topicit_connect.TOPICIT_ENDPOINT}";
       fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'topicit-connect'));
        });
    </script>
    <!-- END switch_topicit_connect -->


Il faut donc remplacer <script> par <script type="text/javascript"> sur la partie cité au dessus, même si le template n'a pas été modifié . Ce qui créé une erreur visible sur W3C .
avatar

jackymi
*****

Masculin
Messages : 505
Inscrit(e) le : 09/12/2011

http://www.skywebforum.com/
jackymi a été remercié(e) par l'auteur de ce sujet.

En cours Re: (#3557) Erreur sur le template overall_footer_end, par défaut

Message par The Godfather le Ven 9 Mar - 9:34

Bonjour @jackymi

Merci pour ce feedback ok

D'un côté vous avez raison. En effet, l'attribut type devrait être passé pour les pages XHTML ou HTML 4 alors que pour les pages HTML 5 ce tag est parfaitement valable.
Mais d'un autre côté, l'immense majorité (peut-être même la totalité) des navigateurs que nous supportons traite de la même façon la balise script qu'elle ait ou non un attribut type... Wink

Du coup si on veut vraiment faire propre, il faudrait effectivement le corriger mais face aux projets en cours et à venir, cela reste vraiment très secondaire et sans urgence. Affirmatif

Nous en prenons donc note et tenterons de faire la modif quand notre planning de développement nous le pellettera.

En vous remerciant encore pour votre vigilance (Code débug : #3557) ::fleur::


avatar

The Godfather
Adminactif
Adminactif

Masculin
Messages : 16255
Inscrit(e) le : 02/05/2004

https://forum.forumactif.com/
The Godfather a été remercié(e) par l'auteur de ce sujet.

En cours Re: (#3557) Erreur sur le template overall_footer_end, par défaut

Message par jackymi le Ven 9 Mar - 21:53

Bonsoir The Godfather

Merci pour cette prise en compte Very Happy
avatar

jackymi
*****

Masculin
Messages : 505
Inscrit(e) le : 09/12/2011

http://www.skywebforum.com/
jackymi a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum