Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Dysfonctionnement des requêtes

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Dysfonctionnement des requêtes

Message par photoclic le Mer 8 Jan 2020 - 21:52

Bonjour,

Je suis confronté depuis plusieurs jour à un dysfonctionnement de l'un de mes scripts.

Après analyse, il apparait que les requêtes ne fonctionnent plus quelque soit le mode:

Code:

    .load('xxxxxx');
    $.get();

Pour exemple, ci dessous un script que m'avait écrit Milouze et qui ne fonctionne plus.
On récupére bien l'url du topic mais aucune image en retour.

Code:
$(function(){          
    if($('a.nav[href^="/c2-"],a.nav[href^="/f16-"]').length) {
      $('dl.icon[style*="https://i.servimg.com/u/f31/19/32/37/01/icon_t30.png"]').closest('div.forumbg').addClass('M14_Annonc');
    $('div.forumbg:not(.M14_Annonc) .M14_LoaD_ToPiCsConT').after('<a href="#" style="margin-left: 5px;" class="M14_LoaD_ToPiCs">Patientez....
    <img src="https://i.servimg.com/u/f11/11/26/21/37/loadin13.gif"style="width:16px !important;height:16px !important;margin-top:10px;"/></a>');
    $('.M14_LoaD_ToPiCs').each(function () {
    var url = this.previousSibling.href;
    var M14_LoaD_ToPiCsLinK=$(this).prev().attr('href');
    $(this).load(url + ' .content:first div:first img:not([longdesc]):first');
     });};});

Merci pour votre aide.


Dernière édition par photoclic le Ven 10 Jan 2020 - 20:28, édité 1 fois
photoclic

photoclic
*****

Masculin
Messages : 907
Inscrit(e) le : 20/11/2015

http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Dysfonctionnement des requêtes

Message par photoclic le Ven 10 Jan 2020 - 1:55

Si un membre du staff pouvait expliquer ce dysfonctionnement peut-être lié à un développement particulier sur FA.

Serais-je le seul à avoir ce souci?
photoclic

photoclic
*****

Masculin
Messages : 907
Inscrit(e) le : 20/11/2015

http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par Faline le Ven 10 Jan 2020 - 8:22

Bonjour,
@photoclic a écrit:Serais-je le seul à avoir ce souci?
Peut-être que non. Reconnaissez-vous votre situation dans
https://forum.forumactif.com/t402143-mes-scripts-javascript-ne-marchent-plus
?
Faline

Faline
Membre habitué

Féminin
Messages : 1331
Inscrit(e) le : 16/08/2006

https://laststickers.forumactif.com
Faline a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par photoclic le Ven 10 Jan 2020 - 12:37

Bonjour Faline,

Je ne saurais vous répondre.
Votre problème semble concerner la majorité de vos JS et aussi sur mobile que je n’utilise pas.

De mon coté, seuls les scripts où il y a des requêtes posent problème.
on récupére bien les url des sujets mais aucune image en retour.

Probablement des évolutions en cours chez FA qui créent ce bug et que je signale ici.
photoclic

photoclic
*****

Masculin
Messages : 907
Inscrit(e) le : 20/11/2015

http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par Tite-May le Ven 10 Jan 2020 - 15:59

Salut !

Le forum concerné est bien celui de ton profil ?
si oui, quand on ouvre la console il y a énormément d'erreur javascript.

As-tu essayé de désactiver tous tes javascripts et de n'activer que celui-ci ? Là il y a vraiment beaucoup d'erreurs et ça peut stopper la lecture de tes scripts et il est super compliqué de s'y retrouver Wink
avatar

Tite-May
***

Féminin
Messages : 199
Inscrit(e) le : 13/08/2012

http://tambouille-raleuses.forumactif.com/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par photoclic le Ven 10 Jan 2020 - 16:14

Bonjour Tite-May,

Merci pour ton aide.

Le forum concerné est bien celui de mon profil.
Je fais des essais et je reviens.

Concernant les erreurs sur mon forum, je serais aussi intéressé par ton aide pour les corriger.
photoclic

photoclic
*****

Masculin
Messages : 907
Inscrit(e) le : 20/11/2015

http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par Milouze14 le Ven 10 Jan 2020 - 20:17

Hello Faline,Tite-May et Serge,

je viens de trouver l'erreur, le script recherche la première div de la div ayant la class content.

Code:
 $(this).load(url + ' .content:first div:first img:not([longdesc]):first');

Le soucis étant que nous avons ajouté dans le template view_topic_body il y a quelque temps
Code:
  <div class="M14_reception_photos"style="display:none"></div>

Donc le script recherche l'image figurant dans cette div, donc le retour est négatif.


Remplaces le par:
Code:

$(function(){         
        if($('a.nav[href^="/c2-"],a.nav[href^="/f16-"]').length) {
          $('dl.icon[style*="https://i.servimg.com/u/f31/19/32/37/01/icon_t30.png"]').closest('div.forumbg').addClass('M14_Annonc');
        $('div.forumbg:not(.M14_Annonc) .M14_LoaD_ToPiCsConT').after('<a href="#" style="margin-left: 5px;" class="M14_LoaD_ToPiCs">Patientez....
        <img src="https://i.servimg.com/u/f11/11/26/21/37/loadin13.gif"style="width:16px !important;height:16px !important;margin-top:10px;"/></a>');
        $('.M14_LoaD_ToPiCs').each(function () {
        var url = this.previousSibling.href;
        var M14_LoaD_ToPiCsLinK=$(this).prev().attr('href');
        $(this).load(url + ' .content:first  div:not(.M14_reception_photos):first  img:not([longdesc]):first');
        });};});


a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 5847
Inscrit(e) le : 18/04/2005

https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Dysfonctionnement des requêtes

Message par photoclic le Ven 10 Jan 2020 - 20:23

Pô pô pô, alors là chapeau Philippe!

Je venais de terminer mes essais de retrait de tous les scripts, bien entendu sans succès.

Les images sont revenues.

Un énorme merci l'ami ok

Bonne soirée à tous.

photoclic

photoclic
*****

Masculin
Messages : 907
Inscrit(e) le : 20/11/2015

http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par Milouze14 le Ven 10 Jan 2020 - 20:25

De rien Serge Wink .
a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 5847
Inscrit(e) le : 18/04/2005

https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Dysfonctionnement des requêtes

Message par photoclic le Ven 10 Jan 2020 - 20:28

Je passe en résolu.
Merci encore.

Me restera à chercher les erreurs de JS soulevés par Tite-May.
photoclic

photoclic
*****

Masculin
Messages : 907
Inscrit(e) le : 20/11/2015

http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum