Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Icône "nouveau message" malgré les parties cachées

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Icône "nouveau message" malgré les parties cachées

Message par Ectra le Jeu 22 Oct 2020 - 22:13

Détails techniques

Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Depuis toujours, à priori. Le forum a ouvert la semaine dernière.
Lien du forum : https://calypsorpg.forumactif.com/

Description du problème

Bonjour, mon soucis est probablement un vieux truc déjà bien connu mais je n'ai rien vu dans mes recherches (mauvais mots clés peut-être).
J'ai des parties cachées, visibles uniquement par certains groupes. Les permissions sont à priori bien paramétrées (lien vers un screen des dites permissions). Le soucis, c'est que malgré que ces parties soient cachées, lorsque quelqu'un poste dedans, absolument tout le monde peut voir l'icone "nouveau message" sur l'index, qui prévient donc qu'un nouveau message a été posté. Sauf que, bien sûr, ils n'ont pas accès à cette partie, et ne la voient même pas. On m'a dit avoir été obligé d'utiliser le lien "Marquer tous les forums comme lus" pour ne plus le voir. (normal me direz vous, vu qu'ils n'ont pas accès pour le lire)

Bref, donc entre les parties cachées et les permissions qui m'ont pourtant l'air correctement paramétrées, je ne comprends pas pourquoi tout le monde a ce "nouveau message", alors qu'ils ne sont pas supposés voir quoi que ce soit de ces parties. Ou alors c'est juste comme ça? Je trouverais ça étonnant.
En guise de solution, je me dis que bêtement isoler ces parties (chacune son sous-forums) ferait que personne ne verrait ça, mais j'aimerais m'assurer ne pas avoir raté quelque chose avant.

En vous remerciant par avance pour votre aide =)
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Ven 23 Oct 2020 - 7:58

Hello Ectra,

un peu de lecture:
https://forum.forumactif.com/t255198-les-groupes#2302905

Et à partir de là et avec l'exemple suivant avec le groupe bidule.
Il faut aller dans le forum via ton P.A:

Général/Catégories et Forums/Catégories et Forums/Le forum en question

Recherches le forum concerné puis cliquer sur l’œil :

Icône "nouveau message" malgré les parties cachées 148

Puis tout décocher sur la ligne "Membres" et ensuite cocher ce que tu souhaites pour le groupe "Bidule":

Icône "nouveau message" malgré les parties cachées 314

Voilou, une fois effectué, tu auras sur les permissions globales du forum cet affichage:

Icône "nouveau message" malgré les parties cachées 219

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Ven 23 Oct 2020 - 13:54

Hey! Merci pour ta réponse! Le soucis c'est que.. bah c'est déjà ce que j'ai fais au départ. J'ai créé le groupe, décoché toutes les permissions "membres" et cochés pour le groupe. Et là je viens d'aller vérifier les permissions DANS le groupe, et c'est bien en accès autorisé. (je vais pas te screen les trucs, c'est exactement comme ce que tu me montres) Donc c'est bien ce que j'ai déjà Confused Une autre idée peut-être?
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Bryx le Ven 23 Oct 2020 - 14:06

Bonjour,

Ce que Milouze te montre, c'est les permissions avancées d'un forum.
Tu peux en lire davantage, ici : https://forum.forumactif.com/t262682-les-permissions#2357238

Bien cordialement
Bryx

Bryx
****

Masculin
Messages : 239
Inscrit(e) le : 03/12/2017

Voir le profil de l'utilisateur https://webtoons.forumactif.com
Bryx a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Ven 23 Oct 2020 - 14:17

Oui oui, j'avais bien compris. Une erreur de ma part, j'avais effectivement laissé des trucs d'éditions paramétrés pour les membres sur l'un des trois groupes, pardon, MAIS le problème demeure, parce que c'était un des groupes bien paramétrés qui postait XD (et y'a aussi une zone admin accessible uniquement par moi, qui laisse voir l'image aussi quand j'y poste)

Je remets les screen du coup vu que les permissions ont changé:
Icône "nouveau message" malgré les parties cachées Captur11
Icône "nouveau message" malgré les parties cachées Captur11
(le "Groupe" dans le zone admin, c'est parce que j'ai donné accès à un compte pnj unique je pense)
Je peux vous screen les permissions avancées mais là tout est coché correctement (pour de vrai cette fois XD) Confused
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Ven 23 Oct 2020 - 17:36

Bonjour
Pouvez-vous fournir une capture d'écran de l'index du forum avec ce bug visible (à partir d'un compte touché) et les permissions d'un forum concerné SVP ? Wink
Pensez à nous préciser l'éventuelle appartenance à un groupe du compte avec lequel vous testez Wink

Bonne journée
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Ven 23 Oct 2020 - 17:41

Bonjour!

Alors, via mon compte membre, et pour la partie où est supposée être la zone admin.
Le sous forum sur l'index (losange bleu = nouveau message; losange orange = pas de nouveau message):
Icône "nouveau message" malgré les parties cachées Captur12
Le sous forum ouvert (où vous pouvez voir que la partie admin est toujours bien cachée, donc aucun losange bleu nulle part):
Icône "nouveau message" malgré les parties cachées Captur13
Et les permissions de la partie entière:
Icône "nouveau message" malgré les parties cachées Captur14

Et le compte que j'utilise est uniquement dans son groupe coloré, qui ne donne aucune permission spéciale. (contrairement à tous les autres comptes du forum, mais nous voyons tous le losange bleu malgré tout)

Merci! =)
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Ven 23 Oct 2020 - 17:55

Bonjour
Merci, j'ai mieux cadré votre problème
Je le reproduis de mon coté sur un forum non modifié Wink

Si un forum a un message non lu contenu dans un sous-forum, l'icône "message non lu" s'affiche même si le membre n'a pas l'autorisation d'accéder au sous-forum concerné...
Serait-il possible que l'équipe jette un œil à ce souci SVP ? Smile
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Ven 23 Oct 2020 - 17:57

C'est tout à fait ça. Et il me semble que c'est pas la première fois que je vois ce soucis, même ailleurs (mais je saurais pas te donner des exemples ou quoi par contre).

(tu parles de quelle équipe, là? Que j'sache si je dois faire quelque chose XD)
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Ven 23 Oct 2020 - 18:06

@Ectra a écrit:(tu parles de quelle équipe, là? Que j'sache si je dois faire quelque chose XD)
De l'équipe de Forumactif Very Happy
La seule chose qu'on pourra faire au niveau Utilisateurs finaux, c'est sortir tous les sous-forums privés des forums publics Very Happy
Pas super pratique.... ^^
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Ven 23 Oct 2020 - 18:08

C'est ça. C'est le plan B auquel j'avais pensé aussi, mais jvoulais passer par ici quand même pour m'assurer qu'il n'y avait pas une "vrai" solution. Parce que c'quand même bizarre u_u
Du coup baaah... patience patience le temps que l'équipe arrive à la rescousse alors. Merci pour ton aide Wink
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Ven 23 Oct 2020 - 18:11

Re Ectra,
hum me parait très étrange ton soucis car personnellement je ne reproduis pas le soucis sur mon fofo de tests.
Si le forum est fermé, personne à part les groupes ne doit le voir ensuite l'image que tu mentionnes (losange bleu) signifie une notification de la catégorie et pas forcément un message dudit forum.

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Ven 23 Oct 2020 - 18:14

Le dit forum étant caché, ils ne peuvent pas le voir, ni son losange, du coup ça se tient. Mais c'est tout de même étrange que toi tu n'arrives pas à reproduire le problème de ton côté. Quand bien même c'est le losange de la catégorie entière, tu devrais l'avoir aussi dans tes tests. Forum possédé u_u
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Ven 23 Oct 2020 - 18:20

Coucou Milouze
Je t'invite à tester comme ceci :
Catégorie X > Forum Y > Sous-forum Z
Un admin
Un membre qui a les droits sur le Forum Y, AUCUN droit sur le sous-forum Z
L'admin poste un message dans Z
Le forum Y passe à "nouveau" sans possibilité de lire le message posté dans Z (chez le membre). La seule solution est donc dans cette situation de marquer tous les forums comme lus Smile
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Sam 24 Oct 2020 - 10:38

Hello Ectra et chattigre,

chattigre, quatorze années passées sur Forumactif et je n'ai jamais vu ce visu sur un groupe!!!!

Parc contre, je vois que tu as autorisé les groupes sur le forum admin sur les deux premières cases,
il faut voir de ce côté et mettre Admin sur toute la ligne.

Icône "nouveau message" malgré les parties cachées Captur10


J'ai testé sur toutes les sortes de configuration au niveau de la compression sur l'index.
Le forum 1 est fermé au membre Paul85 sur mon forum car il ne figure pas dans le groupe bidule (300 messages).
Ce membre n'ayant pas encore atteint ce nombre.

Il voit donc ceci:

Icône "nouveau message" malgré les parties cachées 149

En étant admin,je vois le forum1 et mon dernier message:

Icône "nouveau message" malgré les parties cachées 220

Catégorie X > Forum Y
ou
Catégorie X > Forum Y > Sous-forum Z

Le pauvre Paul85 ne voit absolument rien, preuve à l'appui Very Happy .

Ectra, aurais tu un compte membre à me donner en MP et poster un message de ton côté en tant qu'admin.


a++


Dernière édition par Milouze14 le Sam 24 Oct 2020 - 19:14, édité 1 fois
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Sam 24 Oct 2020 - 11:46

Milouze, tu peux essayer ici, je reproduis le pb Smile
C'est dingue ça Shocked

Tu ne verras pas le sujet dans les derniers messages en effet, mais le forum sera "rouge" (nouveau message)
D'ailleurs, il a l'image "catégorie" avec sous-forums alors que le membre ne voit aucun sous-forum ...
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Sam 24 Oct 2020 - 15:16

Hey, les permissions de la zone admin ont du "groupe" parce que j'ai autorisé un compte unique (dont je me sers pour la gestion) à accéder et poster. Donc c'est normal. Mais ça ne devrait pas jouer sur le problème en question puisque, bah déjà pas logique, et ensuite les autres (des groupes d'intégrations) n'ont pas de comptes uniques autorisés. Enfin bref.

Si la reproduction test de chattigre suffit pas, je peux créer un compte membre temporaire, oui. Confirme-moi ça au besoin =)

J'suis quand même étonné de déterrer un problème pareil à moi tout seul scratch C'est pas rien comme soucis XD
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Sam 24 Oct 2020 - 15:56

Hello,
hum pour le groupe que tu mentionnes est-ce que
ce dernier à une adhésion automatique et si oui combien et ainsi que les autres.
Pour le compte test je veux bien et en mp stp.
Je verrais tout ça dans la soirée car je suis avec mon Android actuellement.
a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Sam 24 Oct 2020 - 16:01

Les trois groupes d'intégrations (chacun a son sous-forum caché) ne sont pas en adhésion automatique, non. Je n'ai aucun groupe en adhésion automatique. Et pour le coup, mon compte membre personnel (qui n'a aucun accès admin), n'est dans aucun de ces groupes et pourtant je vois quand même l'image de nouveaux messages.

Je te ferais le compte test tout à l'heure et t'enverrais les accès par mp

Edit: ça n'a rien donné. D'autres idées? Le plan B reste toujours d'isoler les parties cachées hors des parties visibles. Donc bon, y'a quand même une option, mais c'est tout de même pas normal u_u
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Sam 24 Oct 2020 - 19:24

Re,
comme je n'aime pas rester sur une patte Wink , je vais regarder sur ton fofo de tests chattigre.


@chattigre a écrit:
Milouze, tu peux essayer ici, je reproduis le pb Smile
C'est dingue ça Shocked

Tu ne verras pas le sujet dans les derniers messages en effet, mais le forum sera "rouge" (nouveau message)
D'ailleurs, il a l'image "catégorie" avec sous-forums alors que le membre ne voit aucun sous-forum ...

Hum, il y a un sérieux soucis de compréhension car je ne vois rien de mon côté:

Icône "nouveau message" malgré les parties cachées 151

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Sam 24 Oct 2020 - 19:25

Peut-être parce que c'est comme sur mon forum, il faudrait qu'il poste maintenant que tu es connecté. Sur le mien tu ne voyais rien non plus et j'ai dû reposter, et là tu as vu.
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Sam 24 Oct 2020 - 19:30

Re,
un truc m'interpelle, c'est le widget des derniers sujets:
13 Juillet (date du dernier message ou sujet) .

Icône "nouveau message" malgré les parties cachées 152

Cela prouve bien qu'il ne peut pas y avoir de faille sur les catégories et encore moins
l'information d'une nouvelle notification quel qu’elle soit.

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Sam 24 Oct 2020 - 19:35

Oui, le widget ne montre pas le lien vers le nouveau message, ni là ni chez moi, pourtant l'image de nouveau message est bien là. (sinon ç'aurait forcément été un soucis de permissions... et encore, le problème demeure alors on sait jamais u_u)
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Sam 24 Oct 2020 - 23:22

Coucou Milouze
Je vais poster un message dans le sous forum que tu ne vois pas, tu verras le problème Smile
Pour le moment c'est logique que tout te semble normal ^^
Bonne soirée
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Dim 25 Oct 2020 - 4:50

Hello chattigre,

effectivement, c'est incompréhensible!!
Et quelque soit le niveau de compression de l'index.
Je pense que cela est reliè avec l'arrivé des nouvelles notifications
car il n'y avait pas de soucis avant..

Afin de faciliter la tâche du Staff:

Pouvez vous confirmer que c'est bien l'icône figurant ici:

Affichage/Images et couleurs/Gestion des images/Mode avançé

Icônes du forum ==> Catégorie - Nouveau :
Pour remédier car il y a toujours le lien vers le dernier message, il faut mettre le même lien que:
Icônes du forum ==> Catégorie

Ou:

En attendant, ce script devrait fonctionner pour la version phpbb3:
Il faut impérativement "Séparer les catégories sur l'index ":
Affichage/Page d'acceuil/ Structure et hiérarchie/Niveau de compression de l'index

Séparer les catégories sur l'index : un des trois modes.

Modules/HTML&JAVASCRIPT/Gestion des codes Javascript/Codes Javascript

Activer la gestion des codes Javascript : Oui

Mets un titre explicite.
Cocher sur l'index


Déposer ceci:
Code:

$(function(){
//LE LIEN DE L IMAGE DE REMPLACEMENT
var img="https://2img.net/i/fa/invision/bf_nonew.gif";
//LE LIEN DE L IMAGE NOUVEAU CATEGORIE
var cat="https://2img.net/i/fa/prosilver/forum_unread_category.gif";
$('.forabg').find('ul.topiclist.forums').each(function(){
var li=$(this).find('li').length;
if(li<2)
{
var dl=$(this).find('dl.icon').css('background-image').replace(/^url\(['"](.+)['"]\)/, '$1');
var test=$(this).find('img[class="sprite-icon_topic_latest"][alt="Voir le dernier message"]').length;
if((test)&&(dl=cat))
{
$(this).find('dl.icon').attr('style','background:url('+img+') no-repeat scroll 10px 50%;');
}}
});});



Penser a cliquer sur le bouton VALIDER


Il faut remplacer les liens des images commentées dans le script:
Rappel pour le lien de l'image des catégories:
Icônes du forum ==> Catégorie - Nouveau :
Code:

//LE LIEN DE L IMAGE DE REMPLACEMENT
var img="https://2img.net/i/fa/invision/bf_nonew.gif";

//LE LIEN DE L IMAGE NOUVEAU CATEGORIE

var cat="https://2img.net/i/fa/prosilver/forum_unread_category.gif";
LE LIEN DE L IMAGE DE REMPLACEMENT, correspond à l'image de:
Icônes du forum ==> Catégorie

Le script fonctionnera seulement si il n'y a qu'un forum (ligne) et sans réponse et dans ce cas l'image de remplacement viendra prendre la place de l'image catégorie.

Avant:

Icône "nouveau message" malgré les parties cachées 153

Après:

Icône "nouveau message" malgré les parties cachées 221

Version phpbb2 (sans aucune modification de template) :

Code:
$(function(){
//LE LIEN DE L IMAGE DE REMPLACEMENT
var img="https://2img.net/i/fa/subsilver/category.gif";
//LE LIEN DE L IMAGE NOUVEAU CATEGORIE
var cat="https://2img.net/i/fa/subsilver/category_new.gif";
$('.hierarchy').each(function(){
var tr=$(this).closest('tr').length;
if(tr<2)
{
var dl=$(this).closest('tr').find('td:first img[alt="Nouveaux messages"]').attr('src');
var test=$(this).closest('tr').find('a.last-post-icon img[alt="Voir le dernier message"]').length;
if((test)&&(dl=cat))
{
$(this).closest('tr').find('td:first img[alt="Nouveaux messages"]').attr('src',img);
}}
});});

LE LIEN DE L IMAGE DE REMPLACEMENT, correspond à l'image de:
Icônes du forum ==> Catégorie

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Dim 25 Oct 2020 - 10:08

@Milouze14 a écrit:Hello chattigre,

effectivement, c'est incompréhensible!!
Et quelque soit le niveau de compression de l'index.
Je pense que cela est reliè avec l'arrivé des nouvelles notifications
car il n'y avait pas de soucis avant..

Afin de faciliter la tâche du Staff:

Pouvez vous confirmer que c'est bien l'icône figurant ici:

Affichage/Images et couleurs/Gestion des images/Mode avançé

Icônes du forum ==> Catégorie - Nouveau :
Pour remédier car il y a toujours le lien vers le dernier message, il faut mettre le même lien que:
Icônes du forum ==> Catégorie
Bonjour Milouze
Heureux de voir que je ne suis pas (encore ?) fou Razz
Effectivement c'est bien cette image Smile
Oui il y a bien la solution de mettre deux images identiques mais dans ce cas ça pénalise ceux qui ont accès au sous-forum privé Very Happy
Quant à la date d'apparition de ce problème, je ne parierais rien à ce propos Wink
Bonne journée
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Milouze14 le Dim 25 Oct 2020 - 12:00

Re,

Oui il y a bien la solution de mettre deux images identiques mais dans ce cas ça pénalise ceux qui ont accès au sous-forum privé
Hum non car il y aura dans ce cas précis une notification côté dernier message et le script ne jouera plus sa fonction.

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6325
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par chattigre le Dim 25 Oct 2020 - 12:18

Coucou,
Je parlais d'une solution sans JS avec tout simplement plus d'image nouveau ^^
Comme ici quoi :
@Milouze14 a écrit:Pour remédier car il y a toujours le lien vers le dernier message, il faut mettre le même lien que:
Icônes du forum ==> Catégorie


Ou: [JS]
 Smile
chattigre

chattigre
*****

Masculin
Messages : 934
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Ectra le Dim 25 Oct 2020 - 21:09

Au risque de passer pour un débile: les deux solutions (script, ou non) impliquent du coup de ne plus avoir du tout le losange bleu? Et de se contenter du petit icone du dernier message posté?
Parce que si c'est ça, c'est tout de même pas idéal scratch Je préfère autant séparer les sous-forums concernés. De toute façon, vu comment la visibilité est paramétrée, le groupe ne voit que son sous-forum, donc tant pis, ça en fera un de plus sur l'index Mince
Ectra

Ectra
**

Masculin
Messages : 56
Inscrit(e) le : 25/04/2011

Voir le profil de l'utilisateur https://calypsorpg.forumactif.com
Ectra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Icône "nouveau message" malgré les parties cachées

Message par Delphin67 le Mer 28 Oct 2020 - 19:42

@Milouze14 a écrit:Hello Ectra,

un peu de lecture:
https://forum.forumactif.com/t255198-les-groupes#2302905

Et à partir de là et avec l'exemple suivant avec le groupe bidule.
Il faut aller dans le forum via ton P.A:

Général/Catégories et Forums/Catégories et Forums/Le forum en question

Recherches le forum concerné puis cliquer sur l’œil :

Icône "nouveau message" malgré les parties cachées 148
Rachat de crédit meilleurs taux de banques
Puis tout décocher sur la ligne "Membres" et ensuite cocher ce que tu souhaites pour le groupe "Bidule":

Icône "nouveau message" malgré les parties cachées 314

Voilou, une fois effectué, tu auras sur les permissions globales du forum cet affichage:

Icône "nouveau message" malgré les parties cachées 219

a++
Salut, voici un bon exemple de forum d'entraides, j'ai aussi besoin de cette information. merci bien à vous.
Delphin67

Delphin67
Nouveau membre

Messages : 1
Inscrit(e) le : 26/10/2020

Voir le profil de l'utilisateur https://projetdelphin.com
Delphin67 a été remercié(e) par l'auteur de ce sujet.

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum