Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Help, apparence de mon forum anormal

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Help, apparence de mon forum anormal

Message par photoclic Ven 19 Fév 2021 - 19:05

Bonjour,

Je rencontre un souci sur l'apparence de mon forum https://photoclic.forum-pro.fr/ depuis cet après midi.
Je ne suis pas intervenu sur les scripts ces derniers jours.

La fa_toolbar n'apparait plus en haut de page, et la zone de saisie de la réponse rapide et celle de la messagerie qui sont habituellement sur fond noir sont passées sur fond blanc.

Ceci m'a été remonté par plusieurs membres et le problème se pose pour eux sur edge, chrome et mozilla.
Curieusement, pour ma part, je rencontre le problème sur edge, et mozilla, mais pas sur chrome.

Merci pour votre aide.
photoclic

photoclic
Membre habitué

Masculin
Messages : 1005
Inscrit(e) le : 20/11/2015

Voir le profil de l'utilisateur http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Help, apparence de mon forum anormal

Message par Milouze14 Ven 19 Fév 2021 - 19:08

Hello Serge,
il faut désactiver tous les JS provenant de "fa7up.fr",
le nom de domaine a expiré :
"ERR_CERT_DATE_INVALID" .

Je viens de le voir sur mon propre forum Wink  .

@no_way, si tu passes dans le coin cher ami Very Happy .

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6532
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Help, apparence de mon forum anormal

Message par photoclic Ven 19 Fév 2021 - 19:33

Ah ok Phil. Merci.

J'essaie de trouver ça et reviens vers toi.
photoclic

photoclic
Membre habitué

Masculin
Messages : 1005
Inscrit(e) le : 20/11/2015

Voir le profil de l'utilisateur http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Help, apparence de mon forum anormal

Message par photoclic Ven 19 Fév 2021 - 19:54

Re Philippe,

Alors après plusieurs essais, le JS posant problème est celui-ci:
Code:

//Variables No_Way
$(function(){
        fa7up_mod.getVars().then(x_vars=>{
            var keys=Object.keys(x_vars);
            var regPattern=keys.map(function(e){return new RegExp("[\\{\\[]("+e+")[\\]\\}]","g");});
            var recRep=function(el){
                let a,i=0,liste=el.childNodes,n=liste.length;
                if(el.nodeType===Node.ELEMENT_NODE&&n){
                    for(;i<n;i++){
                        recRep(liste.item(i));
                    }
                }
                if(el.nodeType===Node.TEXT_NODE)for(let idx in regPattern){
                    if(!(a=regPattern[idx].exec(el.nodeValue)))continue;
                    let r=document.createRange();
                    r.setStart(el,a["index"]);
                    r.setEnd(el,a[0].length+a["index"]);
                    r.deleteContents();
                    let div=document.createElement("div");
                    div.innerHTML=x_vars[a[1]];
                    let div_c=div.childNodes,itm;
                    while((itm=div_c.item(0)))r.insertNode(itm);
                    /*Il est probable qu'un élément ait été injecté, il faut reboucler*/
                    recRep(el.parentNode);
                }
            };
            recRep(document.body);
        },error=>{console.error(error)});
    });


Je l'avais mis en place suite à un dysfonctionnement sur FA concernant les variables suivantes:
Nbre de MESSAGES:[FORUMCOUNTPOST]
Nbre de MEMBRES:[FORUMCOUNTUSER]
et DERNIER MEMBRE INSCRIT: [FORUMLASTUSER]

Je crois que FA à régler le problème depuis et vais essayé de remettre les variables originelles dans le template concerné.

Merci pour ton aide Philippe.
photoclic

photoclic
Membre habitué

Masculin
Messages : 1005
Inscrit(e) le : 20/11/2015

Voir le profil de l'utilisateur http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Help, apparence de mon forum anormal

Message par Milouze14 Ven 19 Fév 2021 - 19:59

Re Serge,
entre autre, il y a aussi tout ce qui concerne cette astuce:
https://forum.forumactif.com/t394337-fa7up-installation-simplifiee#3301338

De rien Serge Wink .


a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6532
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Help, apparence de mon forum anormal

Message par photoclic Ven 19 Fév 2021 - 20:06

Dans la liste proposée, en plus des variables, j'avais aussi le Système d'alertes en temps réel.

Le système d'alerte ne semble pas poser de problème.
photoclic

photoclic
Membre habitué

Masculin
Messages : 1005
Inscrit(e) le : 20/11/2015

Voir le profil de l'utilisateur http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Help, apparence de mon forum anormal

Message par photoclic Sam 20 Fév 2021 - 13:50

J'ai remis les variables d'origine pour le Nbre de MESSAGES le Nbre de MEMBRES et le DERNIER MEMBRE INSCRIT.

je passe en résolu et un grand merci encore Philippe (Milouze) pour ta rapidité à trouver l'origine du problème et à ton efficacité.
photoclic

photoclic
Membre habitué

Masculin
Messages : 1005
Inscrit(e) le : 20/11/2015

Voir le profil de l'utilisateur http://photoclic.forum-pro.fr/
photoclic a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum