Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

2 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Ven 11 Juin 2021 - 22:09

Détails techniques

Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Aucune idée des années, je reprends juste le forum après une longue période
Lien du forum : (lien masqué, vous devez poster pour le voir)

Description du problème

Bonjour !

Je reprends tout doucement le codage de mon forum RPG et je rencontre deux problèmes actuellement.

— Je cherche à intégrer le nom du dernier posteur dans la dernière colonne de mes catégories. J'espérais que la balise ci-dessous pourrait fonctionner mais non.. Une idée ?
Code:
{topics_list_box.row.TOPIC_LAST_POST}

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas Sans_t10

— Je cherche également à comprendre pourquoi lorsque moi ou mes membres cliquons sur l'icone "Voir le dernier message" ou "Voir le message le plus récent", le raccourci jusqu'au dernier post ne fonctionne pas. On arrive bien sur le sujet mais la page s'ouvre sur le haut du forum. (Problème identique sur Chrome, Firefox, Edge)
Balise dernier posteur et lien message le plus récent qui ne fonctionne pas Sans_t11

Merci beaucoup pour vos lumières Smile !


Dernière édition par Arnumera le Mar 22 Juin 2021 - 10:53, édité 1 fois
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Lun 14 Juin 2021 - 8:52

Up. Siou plaît  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f607
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Milouze14 Lun 14 Juin 2021 - 19:16

Hello Arnumera,
alors, ce n'est pas une balise mais une variable Wink .

Celle-ci correspondra mieux à tes attentes:
Code:
{catrow.forumrow.LAST_POST}


Je cherche également à comprendre pourquoi lorsque moi ou mes membres cliquons sur l'icone "Voir le dernier message" ou "Voir le message le plus récent", le raccourci jusqu'au dernier post ne fonctionne pas. On arrive bien sur le sujet mais la page s'ouvre sur le haut du forum.

Hum, le template viewtopic_body a été modifié:
Affichage/Templates/Général/viewtopic_body


Merci de le fournir Very Happy .

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6726
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Mar 15 Juin 2021 - 22:53

Coucou par ici, merci Milouze de venir m'aider !
Et merci pour la correction du terme, j'en apprends tous les jours C: !

Malheureusement la variable ne fonctionne pas. Rien ne s'affiche une fois le template en ligne.  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f625

Voici notre viewtopic_body :


Dernière édition par Arnumera le Ven 18 Juin 2021 - 8:51, édité 1 fois
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Ven 18 Juin 2021 - 8:16

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 23eb Up, par ici les copains ! Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f60a
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Milouze14 Ven 18 Juin 2021 - 8:27

Hello Arnumera,

On règle la variable d'abord et ensuite
Affichage/Templates/Général/index_box


Mais tu as déjà les derniers posteurs d'affichés!!! :

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 123

On voit ensuite pourquoi le clic mène en haut de page Wink .




a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6726
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Ven 18 Juin 2021 - 8:59

Bonjour Milouze !  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f44b

Je m'étais tompé de template, je t'ai mis le bon, désolé ! @_@

Voici notre index_box :


Le clic des icones "Voir le dernier message" ou "Voir le message le plus récent" rajoute bien le numéro du post  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 23-20e3  dans l'adresse. Mais on arrive toujours en haut de page  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f625...



Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 27a1 Une autre idée du coup pour la variable qui affiche l'avatar du dernier posteur ?  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f64f

Je ne comprends pas pourquoi
Code:
{catrow.forumrow.avatar.LAST_POST_AVATAR}
fonctionne sur l'index mais pas sur les catégories T_T..
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Milouze14 Ven 18 Juin 2021 - 9:29

Re,

pour les avatars je les vois aussi bien sur (index ou catégorie c'est la même chose)
et aussi sur la liste des sujets sur le fofo mentionné.

Ensuite,

Le clic des icones "Voir le dernier message" ou "Voir le message le plus récent" rajoute bien le numéro du post Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 23-20e3 dans l'adresse. Mais on arrive toujours en haut de page

pour le problème d'ancrage , c'est le template viewtopic_body qu'il faudra chère amie.

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6726
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Ven 18 Juin 2021 - 10:39

Non justement l'avatar visible est celui de l'auteur pas du dernier posteur qui devrait apparaître dans la dernière colonne. Sad

Et perso je ne vois pas d'avatar dans cette dernière..  un soucis de résolution peut être alors ? Ou alors c'est parce que j'ai 3 variables dans une colonne ?

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas Screen10

Sorry je suis sur le téléphone mais le soucis est le même sur pc.


Je vais regarder le soucis d'ancrage ce soir en rentrant du boulot. En bidouillant je vais finir par trouver 😅 Merci !
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Milouze14 Ven 18 Juin 2021 - 19:37

Hello Arnumera,
non l'avatar affiché doit être le dernier membre ayant posté!!!

La preuve en image:

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 124


Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 216
Le lien du dernier message:
https://arnu.forumactif.com/t10-salle-du-throne#36



a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6726
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Ven 18 Juin 2021 - 20:05

Coucou Milouze, attends je me suis emmêlée les pinceaux là t'as raison !! xD

C'est pas la variable de l'avatar du dernier posteur qu'il me faut mais celle qui me donne le nom du dernier posteur! J'ai mélangé l'avatar et le nom en fait...
Roh désolé quelle perte de temps, j'étais pas réveillée du tout en écrivant tout ça  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f602

Le pire c'est que c'est bien ce que j'avais noté dans mon premier post...  Rolling Eyes
Encore désolé T_T !! Ca m'apprendra à faire plusieurs changements en même temps, je ne sais plus ce que je fais au final.


Edit : Du coup j'ai trouvé !
Code:
{topics_list_box.row.LAST_POST_AUTHOR}
Amen T_T


Il me reste juste le soucis de la visualisation du dernier message qui m'envoie en top de page à corriger. Quelle aventure Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f604
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Ven 18 Juin 2021 - 21:29

Alors pour éviter un énième edit, je double post, désolé.

J'ai donc bien trouvé la variable, pas de soucis jusque là. Sauf que dans mon template j'ai une class associée pour faire la mise en forme. Du coup j'ai tout qui s'applique SAUF le text-size. J'ai donc checké sur la console et j'ai une class "gensmall" qui s'applique automatiquement au lien menant au profil du dernier posteur... Du coup ça me mets le texte en riquiqui... au lieu de mon texte-size : 26px... Vu qu'il n'est pas dans mon template, j'avoue que je sèche quant à comment le modifier. J'ai eu beau mettre un !important en espérant que ça modifie la priorité... Bah que dalle. Je sèche  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f62d ..

Je pige pas pourquoi cette classe s'applique en auto sur le "a href" alors que sur la variable de l'auteur du post elle ne s'applique pas. Et le span est le même.

Balise dernier posteur et lien message le plus récent qui ne fonctionne pas Sans_t12



Je cherche toujours si jamais quelqu'un à une idée pour solutionner mon problème d'ancrage au clic du dernier message posté  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f625
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Milouze14 Sam 19 Juin 2021 - 3:54

Hello Arnumera,
alors pour ton ancrage, je n'ai pas de soucis de mon côté avec ton template modifié,
il faudra voir avec le staff pour ce soucis Wink .
Sinon pour ton soucis de taille de police,
rien ne t'interpelle dans ce code html,
si cela est tout riquiqui,peut-être qu'il faudrait augmenter la valeur 10 du font-size.


Code:
 
 <p class="gensmall" style="font-size: 10px; font-family: georgia; text-align: center;">{catrow.forumrow.LAST_POST}</p>

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6726
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Sam 19 Juin 2021 - 7:33

Il n'y a pas de font-size de 10 appliqué à mon span. Mais un de 26 appliqué à la class .catname.
C'est la class "gensmall" qui s'applique automatiquement au lien qui est à 10. Et je voudrais comprendre ce qu'elle vient faire là alors que mon template en est libre. je me suis même amusée à virer toutes les class gensmall appliquées aux autres span du template au cas où mais rien n'y fait.
Surtout que dans la colonne AUTEUR, le span est le même et je n'ai pas ce .gensmall qui s'applique !
J'espère avoir été assez claire ^^

Je te montre le-dit span et template.




Ce .gensmall de 10px n'est pas dans mon CSS. Il arrive de nulle part...  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f628

Vois-tu même si je rajoute une modification avec une nouvelle classe à la balise p, j'ai le même soucis. La class gensmall s'applique au a href et est donc prioritaire alors que ce truc n'est pas, encore une fois, dans mon CSS.
Balise dernier posteur et lien message le plus récent qui ne fonctionne pas Sans_t13

C'est à s'en arracher les cheveux  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f602
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Milouze14 Lun 21 Juin 2021 - 15:39

Hello Arnumera,

purée il faut te suivre entre les templates !!!!!

Car cette variable :
Code:
{topics_list_box.row.LAST_POST_AUTHOR}

Attribue une class gensmall Wink .

Ce style devrait suffire donc (feuille de style) :
Code:
.catname a.gensmall{font-size:26px!important;

a++
Milouze14

Milouze14
Membre actif

Masculin
Messages : 6726
Inscrit(e) le : 18/04/2005

Voir le profil de l'utilisateur https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Balise dernier posteur et lien message le plus récent qui ne fonctionne pas

Message par Arnumera Mar 22 Juin 2021 - 10:52

Haahahaha oui c'est le bazar, j'en peux pluus  Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f602

Bordel mais ouiiiii ! Ca fonctionne !! Moi j'avais juste tenté de mettre en a.gensmall mais ça foirait tout mon QEEL xD.
J'ai complètement zappé de bloquer à la catégorie !
T'es mon héro Milouze ! Merci !! Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f496

Ancrage résolu également avec ceci qui avait disparu de mon viewtropic_body :
Code:
<a name="{postrow.displayed.U_POST_ID}" style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></a>

Tout est bien qui fini bien Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f389
Encore merci merci merci !! Balise dernier posteur et lien message le plus récent qui ne fonctionne pas 1f64c
Arnumera

Arnumera
Nouveau membre

Féminin
Messages : 15
Inscrit(e) le : 11/11/2020

Voir le profil de l'utilisateur https://arnu.forumactif.com/
Arnumera a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum