Problème avec en-tête des catégories après un tuto

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec en-tête des catégories après un tuto

Message par Michi[yo]. le Mar 18 Oct 2011 - 1:33

Bonjour, bonsoir !

Alors voila, j'ai suivi divers tutos pour supprimer les colonnes "Sujets", "Messages" etc pour ne garder que la colonne du titre de la catégorie, mais lorsque je veux supprimer le titre (et le fond, "la bande") de la colonne "Derniers Messages", celle du titre de la catégorie ne s'étend pas jusqu'au bout.

Une image pour illustrer mon problème :
Spoiler:

Pour obtenir un résultat tel qu'ici :
http://tokyo-liar-game.forum-actif.net/
http://pensionnat-rpg.forums-actifs.net/forum
(s'il faut plutôt mettre une capture d'écran au lieu de liens directs, dites-le moi et j'éditerai !)

Merci d'avance !


Dernière édition par Michi[yo]. le Mer 19 Oct 2011 - 20:45, édité 1 fois

Michi[yo].
*

Féminin
Messages : 39
Inscrit(e) le : 09/05/2010

http://redgarden.forumactif.com/forum.htm
Michi[yo]. a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec en-tête des catégories après un tuto

Message par tupac le Mar 18 Oct 2011 - 5:11

Bonsoir Michi[yo]

Il me faudrait votre template index_box pour que je puisse vous explique comment faire.

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec en-tête des catégories après un tuto

Message par Michi[yo]. le Mar 18 Oct 2011 - 20:18

Oui ! Le voici :

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br />
         {CURRENT_TIME}<br />
         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
   <tr>
      <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th><th nowrap="nowrap" width="150"></th></tr>
   <!-- END tablehead -->
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="{catrow.forumrow.INC_CLASS}" align="center" valign="middle">

      </td>

      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
         <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
               <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
         </h{catrow.forumrow.LEVEL}>
         <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
         <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
            {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}
         </span>
      </td>

<td class="row3 over" align="center" valign="middle" height="50">
            <span class="gensmall"></span>

           <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /><br /><span class="gensmall">{catrow.forumrow.LAST_POST}</span>
          </td>

   </tr>
   <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

Michi[yo].
*

Féminin
Messages : 39
Inscrit(e) le : 09/05/2010

http://redgarden.forumactif.com/forum.htm
Michi[yo]. a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec en-tête des catégories après un tuto

Message par tupac le Mer 19 Oct 2011 - 9:43

Bonjour Michi[yo]

Dans votre template index_box repérer la partie suivante.

Code:
  <tr>
      <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th><th nowrap="nowrap" width="150"></th></tr>
et remplacez-la par celle-ci.
Code:
          <tr>
              <th colspan=3 "{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th></tr>

Puis un peu plus bas repérer ceci.

Code:
        <td class="row3 over" align="center" valign="middle" height="50">
                    <span class="gensmall"></span>
       
                  <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /><br /><span class="gensmall">{catrow.forumrow.LAST_POST}</span>
                  </td>
et remplacez-le par cette partie.

Code:
        <td class="row3 over" align="center" valign="middle" height="50"><div style="width:150px;"></div>
                    <span class="gensmall"></span>
       
                  <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /><br /><span class="gensmall">{catrow.forumrow.LAST_POST}</span>
                  </td>

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec en-tête des catégories après un tuto

Message par Michi[yo]. le Mer 19 Oct 2011 - 20:45

C'est parfait merci ! Problème résolu Wink

Michi[yo].
*

Féminin
Messages : 39
Inscrit(e) le : 09/05/2010

http://redgarden.forumactif.com/forum.htm
Michi[yo]. a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum