Appliquer différentes balises à un pseudo via le CSS

Voir le sujet précédent Voir le sujet suivant Aller en bas

  • 0

Résolu Appliquer différentes balises à un pseudo via le CSS

Message par Murtagh le Mar 17 Juil 2012 - 15:40

Bonjour,

Par avance, je m'excuse si ma question n'est pas au bon endroit, j'hésitais entre les "problèmes divers" et celle-ci.

J'ai récemment prit connaissance que l'on pouvait attribuer plusieurs balises via la feuille de style CSS afin de personnaliser le pseudo d'un membre. Dans mon cas, je souhaiterai que cette personnalisation ne s'opère qu'au passage du curseur sur le dit pseudo.

Je me suis renseigné et j'en ai déduis que c'est la balise "hover" qui permet de faire ces changements. Etant une bille en codage, je m'y suis quand même risqué, malheureusement sans succès. Voici le code que j'utilise :
Code:
        a[href="/u1"] span strong {
        color: #820202 !important;
   
}
        a:hover a[href="/u1"] span strong{
  color:#8D8965 !important;
  font-variant:small-caps
}

Ma question est donc : est-il possible de personnaliser un pseudo uniquement au passage de la souris ? (sachant que le code proposé de base proposé fonctionne très bien en continu autrement)

Merci d'avance pour vos réponses. Smile


Dernière édition par Murtagh29 le Mar 17 Juil 2012 - 18:01, édité 3 fois

Murtagh
***

Masculin
Messages : 102
Inscrit(e) le : 04/05/2011

http://www.school-of-pub.net/
Murtagh a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Appliquer différentes balises à un pseudo via le CSS

Message par Anzu le Mar 17 Juil 2012 - 17:03


Bonjour,

Il y a des erreurs dans le code, remplacez par:

Code:
a span strong {
color: #820202 !important;
}

a:hover span strong{
color:#8D8965 !important;
font-variant:small-caps
}

Cordialement.

Anzu
+ Hyperactif +

Féminin
Messages : 20685
Inscrit(e) le : 30/08/2007

http://forum.forumactif.com/forum
Anzu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Appliquer différentes balises à un pseudo via le CSS

Message par Murtagh le Mar 17 Juil 2012 - 17:39

Oui je me doutais que mon code était erroné car je ne savais pas comment personnaliser le code avec "hover". Ca marche parfaitement maintenant. Very Happy Merci beaucoup Anzu pour votre aide.

Edit : Finalement non. Sur mon forum test je n'y ai pas fait attention vu que je suis le seul inscrit, mais le code que vous m'avez proposé s'applique à tous les utilisateurs. Y a t-il une solution pour qu'il ne s'applique qu'au compte "u1" s'il vous plait ?

Edit 2 : Bon finalement j'ai réussi à personnaliser moi-même. Je vous prie de m'excuser. ^^

Murtagh
***

Masculin
Messages : 102
Inscrit(e) le : 04/05/2011

http://www.school-of-pub.net/
Murtagh a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum