[Résolu] [Invision] Javascript qui bug

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mar 14 Oct 2014 - 20:32

Bonsoir

J'utilise ce java pour l'utilisation de flêches haut/bas. La flêche haut fonctionne, celle pour aller en bas ne fonctionne plus.

Code:
$(function(){
                  $("body").append('<div class="bouhautbas"><a href="#top"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche10.gif" alt="Aller en haut" /></a> <a href="#bottom"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche11.gif" alt="Aller en bas"/></a></div>');
        });


Dernière édition par FANCH 56 le Mer 15 Oct 2014 - 15:51, édité 1 fois

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par Polices le Mer 15 Oct 2014 - 10:48

Le code marche parfaitement chez moi, j'ai mis mon forumtest en mode Invision ainsi j'ai inséré votre code dans les js du forum, le bouton bas marche correctement.

Cordialement.

Polices
*****

Masculin
Messages : 511
Inscrit(e) le : 04/07/2011

http://agat.forumofficiel.fr/
Polices a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mer 15 Oct 2014 - 11:00

J'ai oublié de préciser, dans le sujet

Voir ici : http://www.anciens-cols-bleus.net/t12159-mode-d-emploi-pour-une-demande-de-debarquement#bottom

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par AenigmA le Mer 15 Oct 2014 - 11:06

Re insère le (ça arrive)

Code:
$(function(){
                          $("body").append('<div class="bouhautbas"><a href="#top"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche10.gif" alt="Aller en haut" /></a><a href="#bottom"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche11.gif" alt="Aller en bas"/></a></div>');
                });

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par Polices le Mer 15 Oct 2014 - 11:12

Même en re-insérant le code js ça ne va pas marcher.

On dirait que le forum ne reconnait pas le #bottom (bas). Dans la barre d'http:// j'ai essayé #top pour le haut ça marche, par contre j'ai mis par la suite #bottom ça n'a pas fonctionné. Je pense qu'il va falloir l'aide d'un DevActif.

Polices
*****

Masculin
Messages : 511
Inscrit(e) le : 04/07/2011

http://agat.forumofficiel.fr/
Polices a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mer 15 Oct 2014 - 11:13

Bonjour AenigmA

Cela ne fonctionne pas

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par AenigmA le Mer 15 Oct 2014 - 11:19

Bizare oui, il renomme bottom par down chez toi, vois :

Code:
$(function(){$("body").append('<div class="bouhautbas"><a href="#top"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche10.gif" alt="Aller en haut" /></a><a href="#down"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche11.gif" alt="Aller en bas"/></a></div>')});

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mer 15 Oct 2014 - 11:21

Siffleur Non tu as dû regarder au moment ou j'ai fais un essai avec down.......................

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par AenigmA le Mer 15 Oct 2014 - 11:23

Ouf c'est moins pire donc Smile

AenigmA
+ Hyperactif +

Masculin
Messages : 2228
Inscrit(e) le : 10/03/2005

http://aenigma.forumactif.fr/
AenigmA a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par Self le Mer 15 Oct 2014 - 11:46

Bonjour,

Si l'on regarde dans l'inspecteur deux liens (le lien vers ce forum (celui de support) et le lien contact) du footer ont le nom "bottom".
Deux liens que vous n'avez pas dans votre footer, on pourrait afin d'être sur, ajouter le nom "bottom" à tout les liens de ce bas de page, sur votre forum les liens "Invision" et "Signaler un abus".
Remplacez donc le Javascript actuel par :
Code:
$(function(){
   $('.footer-links a').each(function(){ $(this).attr('name', 'bottom') });
   $("body").append('<div class="bouhautbas"><a href="#top"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche10.gif" alt="Aller en haut" /></a> <a href="#bottom"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche11.gif" alt="Aller en bas"/></a></div>');
});

EDIT : je viens de remarquer que vous avez des pages sans le footer, dans ce cas utilisez plutôt ce javascirpt alors :
Code:
$(function(){
   $("body").append('<div class="bouhautbas"><a href="#top"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche10.gif" alt="Aller en haut" /></a> <a href="#bottom"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche11.gif" alt="Aller en bas"/></a></div><a id="bottom" name="bottom"></a>');
});

Self
+ Hyperactif +

Masculin
Messages : 3710
Inscrit(e) le : 13/06/2013

Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mer 15 Oct 2014 - 13:40

Le bouton fonctionne sur 3 cm de descente. Voir les flèches rouges


FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par Self le Mer 15 Oct 2014 - 13:56

Et en insérant :
Code:
<a id="bottom" name="bottom"></a>
dans le template overall_footer_end avant la balise </body>.

Puis avec le Javascript de départ, c'est à dire :
Code:
$(function(){
   $("body").append('<div class="bouhautbas"><a href="#top"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche10.gif" alt="Aller en haut" /></a> <a href="#bottom"><img src="http://i71.servimg.com/u/f71/13/76/08/76/fleche11.gif" alt="Aller en bas"/></a></div>');
});

Self
+ Hyperactif +

Masculin
Messages : 3710
Inscrit(e) le : 13/06/2013

Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mer 15 Oct 2014 - 13:59

Je ne comprends pas ou insérer
Code:
<a id="bottom" name="bottom"></a>

Au temps pour moi. J'avais pas vu "Templates"


EDIT
Aucun changement, sauf que là, la page ne bouge plus du tout en descente.

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par Ea le Mer 15 Oct 2014 - 14:45

Bonjour,


Vous devez avoir dans un template ce que j'ai surligné : http://i.imgur.com/Rx8YIK2.png

Cela met en commentaire tout le bas de la page ( y compris l'élément avec bottom ).

Vu que ça n'agit que sur les sujets, ça doit se trouver dans viewtopic_body.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23428
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: [Résolu] [Invision] Javascript qui bug

Message par FANCH 56 le Mer 15 Oct 2014 - 15:42

J'ai trouvé cela

Code:
  <!-- debut image hosting-->

                <script type="text/javascript">
                  jQuery(function($){
                      $('<a class="sceditor-button sceditor-button-hostimg" unselectable="on" title="héberger une image avec HostingPics"><div unselectable="on"></div></a>').insertBefore('.sceditor-button-servimg');
                      $('.sceditor-button-hostimg').click(function(e){
                        e.preventDefault();
                        if($('.sceditor-hostimg').length == 0){
                            $('<div class="sceditor-dropdown sceditor-hostimg"><p><iframe style="width: 400px; height: 100px;" src="http://www.hostingpics.net/iframe_mini.php" scrolling="no" allowtransparency="true" frameborder="0"> </iframe></p></div>').appendTo('body');
                        }else{
                            $('.sceditor-hostimg').fadeToggle();
                        };
                        var y = $('.sceditor-button-hostimg').offset().top+30;
                        var x = $('.sceditor-button-hostimg').offset().left;
                        $('.sceditor-hostimg').css({'position':'absolute', 'top':y+'px', 'left':x+'px'});
                      });
                  });
                </script>
<!-- Fin image hosting>


EDIT : J'ai remis le template par défaut, et cela fonctionne. Les mystères de l'informatique.

Merci à tous les intervenants.

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum