Problème avec un tutoriel

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec un tutoriel

Message par Zeste le Sam 15 Sep 2012 - 13:00

Rappel du premier message :

Bonjour,

J'ai voulu utiliser ce tutoriel, j'ai suivi tout ce qu'il fallait faire, mais au final, il ne se passe rien. Même en changeant de navigateur. Savez-vous pourquoi ?

Cordialement.


Dernière édition par Daylaton le Sam 29 Sep 2012 - 19:46, édité 1 fois

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Mar 25 Sep 2012 - 18:04

Je pense savoir d'où vient l'erreur, je me suis trompé dans le css là c'est corrigé. Wink

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
          <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br />
         {CURRENT_TIME}<br />
         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><div class="tfa_top">
  <div class="titre_categorie">{catrow.tablehead.L_FORUM}</div>
</div>
 <table class="forumline" id="table_tfa" width="100%" border="0" cellspacing="8" cellpadding="4">
          <!-- END tablehead -->
          <!-- BEGIN forumrow -->
  <tr>     
                    <!-- CELLULE DE GAUCHE -->
              <td class="row3 over" id="tfa_cell_1" align="center" valign="middle" width="20%">
              <!-- ICONE NEW NO-NEW CLOS -->
        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /> 
      <!-- DERNIERS SUJETS -->
        <div class="tfa_last_post">
            <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
        </div>         
      </td>
      <!-- CELLULE DE DROITE -->
      <td class="tfa_cell_2"  valign="middle" width="80%">
      <!-- TITRE FORUM -->
        <div class="block_titre">
        <div class="tfa_titre_forum">
          <div class="titre_gauche"></div>
          <div class="titre_centre">       
            <h{catrow.forumrow.LEVEL} class="hierarchy"> 
        <span class="lien_forum">
      <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
        </span>
            </h{catrow.forumrow.LEVEL}>
          </div>
          <div class="titre_droite"></div>
          <div style="clear:both;"></div>
        </div>
        </div>
      <!-- DESCRIPTION --> 
        <div class="tfa_description">
          <div class="genmed">{catrow.forumrow.FORUM_DESC} </div>     
      <!-- MODERATEUR -->
          <span class="gensmall">
              <!-- BEGIN switch_moderators_links -->
                {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
              <!-- END switch_moderators_links -->           
          </span>
      <!-- SOUS-FORUMS -->
        <span class="sous_forums">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span>         
        </div>
      <!-- SUJETS-MESSAGES -->
        <div class="sujets-messages">
            <span class="gensmall">
              <span class="chiffres">{catrow.forumrow.TOPICS}</span> sujets  et <span class="chiffres">{catrow.forumrow.POSTS}</span> messages
            </span>
        </div>       
      </td>
    </tr>
  <!-- END forumrow -->

  <!-- BEGIN catfoot -->
  <tr>
      <!-- BEGIN inc -->
      <td width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
  </tr>
  <!-- END catfoot -->
  <!-- BEGIN tablefoot -->
</table>
<div class="tfa_bottom"></div>
<img src="{SPACER}" alt="" height="5" width="1" />

<!-- END tablefoot --><!-- END catrow -->

CSS:

Code:
/* CELLULES */
.row3 over#tfa_cell_1, .tfa_cell_2{
background:#84b3cd;
-moz-border-radius:10px;
-webkit-border-radius:10px;
border-radius:10px;
}


Code:
/* TABLE CONTENANT LES CATÉGORIES */
#table_tfa{
background: #96c7d9;
}

Le résultat est un peu...moche. x)
https://i35.servimg.com/u/f35/15/75/02/96/2012-024.png

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par tupac le Mar 25 Sep 2012 - 18:32

Vous l'auriez préféré a droite des derniers sujets postés.
Je regarde ce que je peux faire.

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Mar 25 Sep 2012 - 18:59

En fait, ce serait sans doute mieux. Wink
Et sinon, sur le screen que je vous ai donné, vous voyez ce qui est en bleu clair (le carré), il y aurait pas moyen que les coins soient arrondis?

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par tupac le Mar 25 Sep 2012 - 20:09

Si vous n'avez pas d'arrondi pour cette case c'est parce qu'il y a une erreur dans le css suivant.

Code:
        /* CELLULES */
        .row3 over#tfa_cell_1, .tfa_cell_2{
        background:#84b3cd;
        -moz-border-radius:10px;
        -webkit-border-radius:10px;
        border-radius:10px;
        }
Il fallait mettre une virgule après OVER et un espace comme ceci.
Code:
/* CELLULES */
.row3 over, #tfa_cell_1, .tfa_cell_2{
    background:#84b3cd;
    -moz-border-radius:10px;
    -webkit-border-radius:10px;
    border-radius:10px;
}
En ce qui concerne l'avatar je continu mes recherches.

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Mar 25 Sep 2012 - 20:37

Voilà, c'est corrigé, merci. Wink

Hum vous embêtez pas, je pense que l'avatar serait mieux à droite de l'avatar "Pas de nouveau message". Il suffit de modifier index_box, non?

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Jeu 27 Sep 2012 - 16:57

up

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par tupac le Jeu 27 Sep 2012 - 23:41

Bonsoir

Bon ça devrait fonctionner de cette façon.

Repère cette partie dans la template.

Code:
<span class="tfa_last_post">
    <div class="gensmall">{catrow.forumrow.LAST_POST}</div>
</span>
Remplace-la par celle-ci.

Code:
<div class="tfa_last_post">
      <table><tr><td id="fond_table_dern_mes" class="row3 over"><span class="gensmall">{catrow.forumrow.LAST_POST}</span></td></tr></table>
</div>

Puis dans la feuille de style css trouve ce code.

Code:
/* CELLULES */
.row3 over, #tfa_cell_1, .tfa_cell_2{
    background:#84b3cd;
    -moz-border-radius:10px;
    -webkit-border-radius:10px;
    border-radius:10px;
}
Remplace-le par celui-la.

Code:
/* CELLULES */
.row3 over, #tfa_cell_1, .tfa_cell_2, #fond_table_dern_mes{
    background:#84b3cd;
    -moz-border-radius:10px;
    -webkit-border-radius:10px;
    border-radius:10px;
}
J'y ai juste rajouté ceci #fond_table_dern_mes comme celle qui se trouve dans le nouveau tableau du template pour qu'il prenne aussi la même couleur de fond, le bleue ciel.

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Ven 28 Sep 2012 - 18:52

C'est ça. Merci. Wink

Juste un petit soucis au niveau du CSS :

https://i35.servimg.com/u/f35/15/75/02/96/222210.png

La cellule du centre est double, c'est à dire qu'on a du bleu foncé, et du bleu clair, or je voudrais juste que la cellule soit bleu clair comme l'autre. Savez-vous ce qu'il faut changer?

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par tupac le Ven 28 Sep 2012 - 19:36

Bonjour

J'ai oublié de vous dire de retirer ceci class="row3 over" dans la partie suivante.

Code:
  <!-- CELLULE DE GAUCHE -->
    <td class="row3 over" id="tfa_cell_1" align="center" valign="middle" width="20%">
Je regarde ça pour la cellule double.

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Ven 28 Sep 2012 - 19:44

C'est chose faite. Wink

Je l'ai retiré aussi du CSS.

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par tupac le Ven 28 Sep 2012 - 22:35

Je peux avoir le lien du forum en question ou par MP si vous ne voulez pas le poster a la vu de tous.

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Sam 29 Sep 2012 - 12:57

C'est fait.
Very Happy

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par Zeste le Sam 29 Sep 2012 - 19:11

J'ai trouvé, il suffit d'enlever #fond_table_dern_mes du CSS.

J'attends que vous ayez vu ce message pour le placer en résolu. Wink

Zeste
# Tropactif #

Féminin
Messages : 1366
Inscrit(e) le : 28/11/2010

Zeste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un tutoriel

Message par tupac le Sam 29 Sep 2012 - 19:45

Bonjour

Génial, tu peux donc mettre ton sujet en résolu.

Bon week-end

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum