[Topic Unique] Apparence du nouvel éditeur de messages

Page 8 sur 8 Précédent  1, 2, 3, 4, 5, 6, 7, 8

Voir le sujet précédent Voir le sujet suivant Aller en bas

[Topic Unique] Apparence du nouvel éditeur de messages

Message par marginal le Mer 19 Juin 2013 - 3:17

Rappel du premier message :

MlleAlys...  SVP, ne vous sous-estimez pas.   Sérieux...  la solution proposée a réglé 50 % des problèmes...  incroyable ! MÉGA MERCI !

Il ne reste que les modifications inopérantes en mode WYSIWYG.  Est-ce que ca pourrait venir de Linux ???

@MlleAlys a écrit:en même temps, je n'aurais pas fait cette bête erreur de virgule, ça aurait fonctionné dès le début ><"

les commandes du clavier répondent bien chez moi, sur ce forum comme sur le votre...
(enfin, si j'ai bien compris de quoi il s'agissait ^^")

EDIT : SeLfde4Th7, ce code, c'est pour les espaces avant et après la citation... est ce que c'est de ça qu'on parle ? (j'aurais encore mal compris ? xD


@marginal a écrit:Même ici, je suis pas capable d'utiliser les flèches, le backspace et le delete.....   fonctionne pas en mode WYSIWYG.  

Dis, mlleAlys,  Tu es ou sur la planète... je t'en doit une...  sérieux !   Very Happy

Martin

@MlleAlys a écrit:
@marginal a écrit:alleluya !!!!!!!!!!!!  Toutes les fenêtres peu importe le mode sont de même couleur !!!  

J'ai aucune idée quel code a fait ca mais MelleAlys... vous avez fait le travail !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!  MERCI !

c'était donc bien cette fichue petite virgule qui gâtait tout le code ! ><"



@marginal a écrit:Maintenant le seul soucy qu'il me reste, c'est qu'en mode WYSIWYG, les flèches, le back space, et la touche delete ne fonctionnent pas...

Des idées ?  

Euh... c'est à dire ? ^^"
(mais j'ai bien peur que non =S)

marginal
*

Messages : 47
Inscrit(e) le : 19/03/2011

http://passionvoile.forumcanada.net/forum
marginal a été remercié(e) par l'auteur de ce sujet.

Re: [Topic Unique] Apparence du nouvel éditeur de messages

Message par Shadow le Ven 26 Juil 2013 - 16:36

@le.cricket a écrit:6 semaines plus tard nous sommes toujours en noir & blanc ! Quand je disais dans un de mes posts que nous aurions la solution fin d'année c'est bien parti !!! Il est hors de question que je mette du "provisoire" en place pour devoir recommencer mais peut-être que les responsables du nouvel éditeur sont en vacances aussi ! En attendant nous sommes toujours dans le même bazar (pour ne pas être vulgaire !) Je crois que là ça commence à faire beaucoup ! Nous n'avions rien demandé, alors rendez-moi la couleur de mon forum dans l'éditeur !!! Merci à vous !

Bonjour,

Non nous ne sommes pas en vacances et la résolution des problèmes signalés avance sauf que cela prend du temps.

Merci de votre compréhension et bonne fin de journée Wink


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Shadow
Adminactive
Adminactive

Féminin
Messages : 23784
Inscrit(e) le : 30/03/2007

http://forum.forumactif.com
Shadow a été remercié(e) par l'auteur de ce sujet.

Re: [Topic Unique] Apparence du nouvel éditeur de messages

Message par Romjé le Ven 26 Juil 2013 - 22:49

Bonsoir,
j'ai commencé à modifier l'éditeur grâce au Tuto/compte rendu de Tech.

je suis allé aussi ici :
http://forum.forumactif.com/t352532-topic-unique-apparence-du-nouvel-editeur-de-messages
Mais j'ai pas trouvé de solution.

Je n'arrive pas à supprimer ces bordures :



 voici ce que j'ai entré dans CSS :

Code:
.sceditor-container
{
width: 98% !important;
margin: auto !important;
border: none !important;
background: #ffffff !important;
}
.sceditor-toolbar
{
  background: #737373 !important;
  border-bottom: 1px solid #737373 !important;
}
.sceditor-group
{
  background: #c4c4c4 !important;
  border: 0px outset #737373 !important;
  border-radius: 5px !important;
}
.sceditor-container textarea, .sceditor-container iframe
{
  padding: 5px !important;
  background: #c4c4c4!important;
  border: 0px solid #c4c4c4 !important;
}

1er problème : 
Comment supprimerle bord blanc? dans l'éditeur 
car dans la zone smileys j'ai trouvé comment faire.

2ème problème :
J'ai voulu changer les pictos des boutons
car ils sont noir et sur le fond gris ça ne ressort pas
je voulais un fond + foncé et mettre les boutons (Gras, italic, souligné, etc…) en blanc.
j'ai essayé avec CSS mais ça n'a rien donné.
j'ai portant fait un fichier en 16x16 px.
j'ai essayé en .png, . gif, que faut il comme extension?

3ème problème :
comment modifier la couleur du texte dans l'éditeur?
il est noir, j'aimerai le passer blanc pour foncer le fond.

4ème problème:
peut on changer la couleur du pavé de citation?
aujourd'hui jaune par défaut.
ainsi que la couleur du texte?

j'ai mis ce code javascript mais ça ne fait rien :

Code:
$(function(){ $(function() {
          $('.sceditor-container iframe').contents().find('head').append('<style type="text/css">
body, p {
    background: #525252;  /*couleur de fond de la zone de saisie*/
    color: #FAFAFA;  /*couleur de la police dans la zone de saisie*/
}
blockquote, blockquote cite, code {
    background-color: #525252;  /*couleur de fond des citations et codes*/
    color: #FAFAFA; /*couleur de la police dans les citations et les codes*/
    border: 1px solid #525252; /*bordure des citations et codes*/
}
code:before {
    color: #525252;  /*couleur du mot -code-*/
}



Merci beaucoup par avance.

Romjé
**

Masculin
Messages : 63
Inscrit(e) le : 10/03/2011

http://teamquad28.forumactif.com/
Romjé a été remercié(e) par l'auteur de ce sujet.

Re: [Topic Unique] Apparence du nouvel éditeur de messages

Message par MlleAlys le Sam 27 Juil 2013 - 1:26

Bonjour !
Concernant le cadre autour des smileys, il s'agit en fait de la couleur de fond de l'encadré, vous pouvez la modifier via ce code css, en remplaçant COULEUR par le code de la couleur de votre choix :
Code:
#sceditor_smilies {
  background-color: COULEUR;
}
ou bien la supprimer via ce code-ci :
Code:
#sceditor_smilies {
  background : none;
}

Pour le cadre autour de la zone de texte, j'avoue que je ne sais pas trop, mais si vous avez un lien vers un forum ouvert aux invités ça m'aiderait =S


Pour modifier les boutons, .png comme .gif ou .bmp fonctionnent :
- créez votre image en 16px*16px, enregistrez la.
- hébergez la, avec servimg par exemple, ou autre.
- récupérez l'url de l'image ("lien direct de l'image" sur servimg)
- récupérez la class du bouton que vous souhaitez modifier :
Spoiler:
gras :
.sceditor-button.sceditor-button-bold

italique :
.sceditor-button.sceditor-button-italic

souligner :
.sceditor-button.sceditor-button-underline

barré :
.sceditor-button.sceditor-button-strike

aligner à gauche :
.sceditor-button.sceditor-button-left.active

centrer :
.sceditor-button.sceditor-button-center

aligner à droite :
.sceditor-button.sceditor-button-right

justifier :
.sceditor-button.sceditor-button-justify

liste :
.sceditor-button.sceditor-button-bulletlist

liste ordonnée :
.sceditor-button.sceditor-button-orderedlist

barre horizontale :
.sceditor-button.sceditor-button-horizontalrule

citer :
.sceditor-button.sceditor-button-quote

code :
.sceditor-button.sceditor-button-code

spoiler :
.sceditor-button.sceditor-button-faspoiler

caché :
.sceditor-button.sceditor-button-fahide

tableau :
.sceditor-button.sceditor-button-table

héberger image :
.sceditor-button.sceditor-button-servimg

insérer une image :
.sceditor-button.sceditor-button-image

insérer un lien :
.sceditor-button.sceditor-button-link

taille police :
.sceditor-button.sceditor-button-size

couleur police :
.sceditor-button.sceditor-button-color

police :
.sceditor-button.sceditor-button-font

supprimer formatage :
.sceditor-button.sceditor-button-removeformat

youtube :
.sceditor-button.sceditor-button-youtube

dailymotion :
.sceditor-button.sceditor-button-dailymotion

flash :
.sceditor-button.sceditor-button-flash

bouton "..." :
.sceditor-button.sceditor-button-more

indice :
.sceditor-button.sceditor-button-subscript

exposant :
.sceditor-button.sceditor-button-superscript

défilement horizontal :
.sceditor-button.sceditor-button-fascroll

défilement vertical :
.sceditor-button.sceditor-button-faupdown

wow :
.sceditor-button.sceditor-button-fawow

aléatoire :
.sceditor-button.sceditor-button-farand

smiley :
.sceditor-button.sceditor-button-emoticon

date :
.sceditor-button.sceditor-button-date

heure :
.sceditor-button.sceditor-button-time

insérer texte :
.sceditor-button.sceditor-button-pastetext

changer mode :
.sceditor-button.sceditor-button-source
- utilisez comme suit :
Code:
.class-du-bouton div {
  background-image:url(URL DE L'IMAGE);
  background-position: 0;
}
.class-du-bouton doit être remplacé par la class du bouton voulu donnée dans le spoiler au dessus (n'oubliez pas d'ajouter le div derrière), et URL DE L'IMAGE par l'url de la nouvelle image du bouton hébergée auparavant.

Votre 3ième et 4ième problèmes devraient être réglés avec le code javascript : ce que vous donnez est-il vraiment votre code complet ? Si oui, il manque une partie à la fin du code (que vous avez peut être perdue en voulant retirer le commentaire entre /*...*/) :
Code:
$(function(){ $(function() {
          $('.sceditor-container iframe').contents().find('head').append('<style type="text/css">
body, p {
    background: #525252;  /*couleur de fond de la zone de saisie*/
    color: #FAFAFA;  /*couleur de la police dans la zone de saisie*/
}
blockquote, blockquote cite, code {
    background-color: #525252;  /*couleur de fond des citations et codes*/
    color: #FAFAFA; /*couleur de la police dans les citations et les codes*/
    border: 1px solid #525252; /*bordure des citations et codes*/
}
code:before {
    color: #525252;  /*couleur du mot -code-*/
}
</style>')
        })});

Si non, vos codes javascripts sont ils bien activés ? Ce code est il bien mis sur toutes les pages ? Si oui, et que le problème persiste toujours, alors il s'agit peut être d'une erreur dans un autre de vos codes javascript si vous en avez... Et dans ce cas je ne suis pas capable de vous aider, je ne m'y connais pas assez T-T

MlleAlys
+ Hyperactif +

Messages : 4340
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Problème avec l'éditeur

Message par RegFug le Sam 27 Juil 2013 - 8:09

Bonjour
J'ai un problème avec l'éditeur de texte sur mon forum
Je cherche depuis quelques jours la solution sur ce forum d'entraide mais en vain.

Voilà : depuis quelques jours, quand on veux mettre (sur mon forum) un texte en gras ou en italique ou en souligné, ou bien qu'on veut le centrer ou justifier, etc. etc..., quand on valide le message, ça affiche la même chose qu'en mode édition au lieu d'afficher le résultat espéré.

Idem quand je met un texte en citation : au lieu d'apparaître le cadre habituel, ça apparaît comme en mode édition, tout en texte (quote, etc...)

Merci d'avance si vous avez la solution.

RegFug
Nouveau membre

Messages : 6
Inscrit(e) le : 10/03/2012

http://essania.actifforum.com/
RegFug a été remercié(e) par l'auteur de ce sujet.

Re: [Topic Unique] Apparence du nouvel éditeur de messages

Message par MlleAlys le Sam 27 Juil 2013 - 13:34

@RegFug a écrit:Bonjour
J'ai un problème avec l'éditeur de texte sur mon forum
Je cherche depuis quelques jours la solution sur ce forum d'entraide mais en vain.

Voilà : depuis quelques jours, quand on veux mettre (sur mon forum) un texte en gras ou en italique ou en souligné, ou bien qu'on veut le centrer ou justifier, etc. etc..., quand on valide le message, ça affiche la même chose qu'en mode édition au lieu d'afficher le résultat espéré.

Idem quand je met un texte en citation : au lieu d'apparaître le cadre habituel, ça apparaît comme en mode édition, tout en texte (quote, etc...)

Merci d'avance si vous avez la solution.

Bonjour,
ce problème ne concerne pas l'apparence de l'éditeur, ce à quoi est dédié ce sujet, et je vous ai d'ailleurs répondu ici : http://forum.forumactif.com/t352531p450-topic-unique-html-nouvel-editeur-de-messages#3023692 Wink

MlleAlys
+ Hyperactif +

Messages : 4340
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Re: [Topic Unique] Apparence du nouvel éditeur de messages

Message par Tech le Sam 27 Juil 2013 - 14:39

Bonjour à tous,

Le topic unique est dorénavant fermé. Ceux qui rencontrent encore des problèmes, merci d'ouvrir votre propre sujet afin d'avoir un meilleur rendement de l'entraide.

Il est inutile de poster un sujet si votre problème se trouve dans le Compte rendu (celui-ci a été mis à jour) ! Si il est dans le compte rendu, c'est qu'il sera corrigé.

Merci de votre compréhension.
Cordialement.



{ Règles Générales } { Question & Réponses Fréquentes } { Le Staff de ForumActif }

Tech
Modéractif
Modéractif

Masculin
Messages : 20898
Inscrit(e) le : 01/12/2007

http://forum.forumactif.com
Tech a été remercié(e) par l'auteur de ce sujet.

Page 8 sur 8 Précédent  1, 2, 3, 4, 5, 6, 7, 8

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum