Problème Html dans un message.

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 19:28

Bonjours,

J'ai un soucis avec l'intégration d'un code html dans un message.
Voici une parti du code en question:

Spoiler:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
<head>
<title>Bienvenue sur mon site !</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>
</body>
</html>


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr" dir="ltr">
<head>

<link rel="shortcut icon" href="/sites/all/themes/swtor/favicon.ico" type="image/x-icon" />
<link rel="alternate" keywords="info" type="application/atom+xml" title="Star Wars: The Old Republic | Le Jeu" href="http://www.swtor.com/fr/flux/lejeu/tout" />
<link type="text/css" rel="stylesheet" media="all" href="http://cdn-www.swtor.com/sites/all/files/css/css_0cf58241749f0dce37811db443e20e36.css" />
<link type="text/css" rel="stylesheet" media="screen" href="http://cdn-www.swtor.com/sites/all/files/css/css_7379d4abc7aa3e2a86ff87e3a013d6f5.css" />
<link type="text/css" rel="stylesheet" media="print" href="http://cdn-www.swtor.com/sites/all/files/css/css_20b28e02af17fa848fb524d023e80b06.css" />
<script type="text/javascript">
var drupal_theme_loc = "/sites/all/themes/swtor/";
var swtor_theme_loc = "/sites/all/themes/swtor/";
</script>
<script type="text/javascript" src="http://cdn-www.swtor.com/sites/all/files/js/js_a7ba29437e3b153ec2b81ce7574fccd8.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","fivestar":{"titleUser":"Votre Estimation : ","titleAverage":"Moyenne: ","feedbackSavingVote":"\x26#201;conomie...","feedbackVoteSaved":"\x26#201;conomis\x26#233;.","feedbackDeletingVote":"Suppression...","feedbackVoteDeleted":"Supprim\x26#233;."},"cdnpath":"http:\/\/cdn-www.swtor.com\/","swtor_login_error_dropdown":[]});
//--><!]]>
</script>
<!--[if lt IE 8]>
<link type="text/css" rel="stylesheet" media="all" href="http://cdn-www.swtor.com/sites/all/themes/swtor/css/stylesIE.css" />
<![endif]-->
<!--[if IE 6]>
<script type="text/javascript" src="http://cdn-www.swtor.com/sites/all/themes/swtor/js/jquery.ifixpng.js"></script>
<link type="text/css" rel="stylesheet" media="all" href="http://cdn-www.swtor.com/sites/all/themes/swtor/css/stylesIE6.css" />
<![endif]-->
Et voici ce que cela donne sur le message;

Spoiler:

Voilà, merci d'avance pour la grande aide que vous pourriez m'apporter.

Incub.


Dernière édition par Incubateur le Sam 25 Juin 2011 - 10:21, édité 1 fois

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Pakodar le Ven 24 Juin 2011 - 19:30


Pakodar
*****

Masculin
Messages : 669
Inscrit(e) le : 22/12/2010

http://ogamemaio.forumgratuit.org/forum
Pakodar a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 19:39

Merci mais ce tutoriel ne m'aide pas énormément puisque mon code s'affiche mais pas en entier. (et la partie affiché ce déforme).

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Pakodar le Ven 24 Juin 2011 - 19:44

En effet.
Essayez ceci:

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
<head>
<title>Bienvenue sur mon site !</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>
</body>
</html>


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr" dir="ltr">
<head>

<link rel="shortcut icon" href="/sites/all/themes/swtor/favicon.ico" type="image/x-icon" />
<link rel="alternate" keywords="info" type="application/atom+xml" title="Star Wars: The Old Republic | Le Jeu" href="http://www.swtor.com/fr/flux/lejeu/tout" />
<link type="text/css" rel="stylesheet" media="all" href="http://cdn-www.swtor.com/sites/all/files/css/css_0cf58241749f0dce37811db443e20e36.css" />
<link type="text/css" rel="stylesheet" media="screen" href="http://cdn-www.swtor.com/sites/all/files/css/css_7379d4abc7aa3e2a86ff87e3a013d6f5.css" />
<link type="text/css" rel="stylesheet" media="print" href="http://cdn-www.swtor.com/sites/all/files/css/css_20b28e02af17fa848fb524d023e80b06.css" />
<script type="text/javascript">
var drupal_theme_loc = "/sites/all/themes/swtor/";
var swtor_theme_loc = "/sites/all/themes/swtor/";
</script>
<script type="text/javascript" src="http://cdn-www.swtor.com/sites/all/files/js/js_a7ba29437e3b153ec2b81ce7574fccd8.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","fivestar":{"titleUser":"Votre Estimation : ","titleAverage":"Moyenne: ","feedbackSavingVote":"\x26#201;conomie...","feedbackVoteSaved":"\x26#201;conomis\x26#233;.","feedbackDeletingVote":"Suppression...","feedbackVoteDeleted":"Supprim\x26#233;."},"cdnpath":"http:\/\/cdn-www.swtor.com\/","swtor_login_error_dropdown":[]});
//--><!]]>
</script>
<!--[if lt IE 8]>
<link type="text/css" rel="stylesheet" media="all" href="http://cdn-www.swtor.com/sites/all/themes/swtor/css/stylesIE.css" />
<![endif]-->
<!--[if IE 6]>
<script type="text/javascript" src="http://cdn-www.swtor.com/sites/all/themes/swtor/js/jquery.ifixpng.js"></script>
<link type="text/css" rel="stylesheet" media="all" href="http://cdn-www.swtor.com/sites/all/themes/swtor/css/stylesIE6.css" /></head></html>
<![endif]-->

Il manquait la balise de fermeture </head> et peut-être (dîtes le moi si je me trompes) </html>.

Pakodar
*****

Masculin
Messages : 669
Inscrit(e) le : 22/12/2010

http://ogamemaio.forumgratuit.org/forum
Pakodar a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 19:51

Bonjour

Il me semble que les scripts ne sont pas acceptés dans les messages pour raison de sécurité.

Il faudrait à ce moment la faire fonctionner votre code dans une page html et ensuite l'insérer en iframe dans un post.
Cordialement.


Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 19:54

Merci mais cela ne fonctionne pas plus. Et puis ceci n'est qu'une infime partie du code que je ne peux malheureusement pas poster en entier à cause de sa longueur. Si ça peut aider, lorsque je le lance tel quel sur mon navigateur, ça passe sans problème.

Et voici ce que ça donne:



Je pense qu'il s'agit d'une incompatibilité entre mon code et le forum.

Merci Adam__sfp. Comment le faire Wink ?

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 20:05

Bonsoir

il est censé faire quoi ce code?
Vous avez bien mis tous les liens des différents fichiers utiles hébergés?
Logiquement si votre code fonctionne sur une page html du forum il fonctionne en iframe.

Cordialement.

Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 20:20

Voila la page hebergée. http://www.jabry.net/cpanel/edit.asp?a=edit&f=0|test3%2Ehtml&m=h

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 20:37

@Incubateur a écrit:Voila la page hebergée. http://www.jabry.net/cpanel/edit.asp?a=edit&f=0|test3%2Ehtml&m=h
Bonjour

je n'ai pas accès à cette page...

Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 20:42

D'accord .... Pouvez-vous me conseiller un hébergeur gratuit dans ce cas ?

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 20:46

Bonsoir

Vous pouvez essayer archive host.

Cordialement.

Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 20:49

J'espère que celui-ci fonctionne.
http://www.archive-host.com/files/1082693/812bfc5bc514dd00fc4cd6bbab746c305c8ea536/Test2.html

Désolé du dérangement :/ .

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 20:53

Oui celui ci fonctionne
et vous voulez mettre ceci dans un message?
un peu grand dans un post non?


Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 20:54

Oui j'en ai peur (je ne sais pas comment le réduire ><'). Est-ce que ça pose un réel problème ?

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 20:59

Bonsoir

C'est très large Shocked

Pourquoi ne pas le mettre dans une page HTML de votre forum et mettre un lien (lien sur une image) vers celle ci ?

Cordialement.


EDIT

Petite question avez vous l'autorisation de ce site

http://www.swtor.com/fr/lejeu/systemes/classes-avancees

Pour utiliser leurs images ,codes, bande passante...?

Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Incubateur le Ven 24 Juin 2011 - 22:38

Non pas encore d'autorisation. J'ai envoyé un mail au modérateurs du forum de la communauté swtor pour l'obtenir. J'attend de toute façon un autorisation légale pour diffuser quelque contenu que ce soit. Je prévois juste les questions technique pour une mise en ligne le plus rapidement possible dès que je reçoit leur réponse (si positive). Voila. De toute façon vu le problème de taille que je rencontre, je pense juste mettre un lien vers leurs site Smile.

Incubateur
Nouveau membre

Messages : 11
Inscrit(e) le : 14/04/2011

http://la-legion-blanche.forumgratuit.org/
Incubateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème Html dans un message.

Message par Adam_sfp le Ven 24 Juin 2011 - 22:49

Bonjour,

Afin de faciliter la gestion des problèmes, si votre problème est résolu, pensez à :
  • éditer votre premier message,
  • cocher l'icône résolu
  • Et enregistrer en cliquant sur


Vous pouvez également remercier les personnes qui vous ont aidé, en cliquant sur le bouton

A bientôt sur ForumActif Smile

Adam_sfp
+ Hyperactif +

Masculin
Messages : 4157
Inscrit(e) le : 18/04/2008

http://antonyadam.1fr1.net/portal.htm
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum